Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2019-11-01 20:05:29

burma
Contributor
Registered: 2018-07-28
Posts: 13

Unknown LF (farpointe?)

Hi, I'm trying to read an access card (regular thin plastic with 4 small dots on 2 sides and a text 3061 11814 H), but I can't figure out how to do the demodulation.

pm3 --> lf search 0 u          
NOTE: some demods output possible binary
  if it finds something that looks like a tag          
False Positives ARE possible
          

Checking for known tags:
          
          
[-] No known 125/134 KHz tags Found!
          
          
[=] Checking for Unknown tags:
          
[-] no repeating pattern found          
          
[-] No Data Found!

lf306111814h.png

Any suggestions on what can I try to parse this signal?

The bit seems to be 50 samples long and the pattern repeats on different read attempts

Saved trace data: https://pastebin.com/dl/MFjVQcxW

Thank you

Offline

#2 2019-11-02 14:26:56

iceman
Administrator
Registered: 2013-04-25
Posts: 5,845
Website

Re: Unknown LF (farpointe?)

the signal isn't the best.   Are you running on the latest source for RRG/Iceman repo?  It doesn't look like it.
I also would try 134khz sampling.

data plot
lf conf H
lf read
data save lf_unk_farpoint_3061_11814.pm3

If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#3 2019-11-02 20:41:28

burma
Contributor
Registered: 2018-07-28
Posts: 13

Re: Unknown LF (farpointe?)

I've tried installing the most recent RDV windows client, flashed it (after forecefully assigning COM port after flashing bootrom to match what was used for flashing the bootrom since it was being changed in between by Windows). Then, unfortunately, it wasn't being recognized by Windows (device descriptor request failed @ Windows 10 x64) 99% of the time.

It worked by chance only once when I was holding the hardware button (not while in bootloader mode). When it did, I've noticed it was unable to read LF cards that were being perfectly read with previous firmware.

I've flashed July 31 version then since it was 4MB larger and that did the trick, the device is now recognized by Windows. I'm still having problems reading my LF cards (T5577, EM410) -- it gets the signal but just doesn't read them anymore.

Long story short -- not the best build for my device. I'm struggling to make it work and might be forced to revert to some earlier version

However, I've managed to get partial readings while holding the unknown card 3-4 cm above the antenna (instead of just placing it on top of it)

[usb] pm3 --> lf search -u
[=] NOTE: some demods output possible binary
[=] if it finds something that looks like a tag
[=] False Positives ARE possible
[=]
[=] Checking for known tags...

[+] HID Prox TAG ID: 2004165c4d (11814) - Format Len: 26bit - OEM: 000 - FC: 11 - Card: 11814

[+] Valid HID Prox ID found!

The card is confirmed to be Farpointe. "3061" piece is still missing; maybe should configure more bits in HID Prox reader function?

lf_unk_farpoint_3061_11814_l.pm3 https://pastebin.com/dl/mimTz68q
lf_unk_farpoint_3061_11814_h.pm3 https://pastebin.com/dl/xnp23QsT

Offline

#4 2019-11-02 21:21:24

iceman
Administrator
Registered: 2013-04-25
Posts: 5,845
Website

Re: Unknown LF (farpointe?)

You will need to flash bootrom, if you haven't updated your device for a while.


..pull latest,  compile,  flash bootrom,  flash fullimage,  run client


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#5 2019-11-02 21:21:46

iceman
Administrator
Registered: 2013-04-25
Posts: 5,845
Website

Re: Unknown LF (farpointe?)

Still,  not unknown any longer,  HID prox.


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#6 2019-11-03 21:39:08

burma
Contributor
Registered: 2018-07-28
Posts: 13

Re: Unknown LF (farpointe?)

iceman wrote:

Still,  not unknown any longer,  HID prox.

Yup. I tried to treat it as HID and the reader seems to accept it. After all both HID and Farpointe are using 26bit Wiegand

iceman wrote:

You will need to flash bootrom, if you haven't updated your device for a while.


..pull latest,  compile,  flash bootrom,  flash fullimage,  run client

Yes, I did flash the bootrom and fullimage successfully. It didn't work still unfortunately. Windows 10 x64 only recognizes the device in bootloader mode. In regular mode it  gives "device descriptor request failed" error and no driver update (signature verification disabled) works.

The last version that works for me so far is of 31-Jul-2019. I'll try few more things

Last edited by burma (2019-11-03 21:42:31)

Offline

#7 2019-11-04 01:54:21

mwalker
Contributor
Registered: 2019-05-11
Posts: 188

Re: Unknown LF (farpointe?)

"device descriptor request failed"
I assume this is what you see in device manager in windows?
What happens if you right click and uninstall those devices, then unplug the pm3 and reboot.  Then connect and see if it can find it.

Offline

#8 2019-11-04 17:54:07

iceman
Administrator
Registered: 2013-04-25
Posts: 5,845
Website

Re: Unknown LF (farpointe?)

To keep the forum clean,  we prefer one subject per thread.

I suggest OP start a new thread for questions about compile/flash failures.  And search the forum for similar threads before, since there are aleast 20 threads on that subject already.


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

Board footer

Powered by FluxBB